Back to overview
Resolved
im renaming the guest wifi
Jul 14, 2026 at 2:55pm UTC
–
Jul 14, 2026 at 3:34pm UTC
Affected services
Orbit Site
Resolved
Jul 14, 2026 at 3:34pm UTC
im done renaming the guest wifi
Affected services
Updated
Jul 14, 2026 at 3:34pm UTC
Maintenance ended
Affected services
Created
Jul 14, 2026 at 2:55pm UTC
its going to be peak trust
internet will die
Affected services