Back to overview
Resolved

Orbit login currently nonfunctional

Jul 13, 2026 at 7:15pm UTC
Affected services
Orbit Site

Resolved
Jul 14, 2026 at 12:42pm UTC

We ran some fixes and it seems the issue is resolved.

All operations are now back to usual.

Updated
Jul 14, 2026 at 12:38pm UTC

We have identified the cause of the login not functioning.

We will be investigating further, including reaching out to the developers of the software we are using.

Updated
Jul 14, 2026 at 12:03pm UTC

We haven’t found the time to work on this issue. Altough, we will start the repairs soon.

Created
Jul 13, 2026 at 7:15pm UTC

We are investigating issues with the login system of the Orbit Instance.

Please bare with us as we investigate and be patient.